当前位置:首页 > 问答

通达信三日内有涨停

我来帮TA回答

求助,通达信3日内有过涨停的选股公式。在下先谢了!

今涨停:=C/REF(C,1)>1.09;
选股:COUNT(今涨停,N);
参数自设,几日都可以

通达信 选3天内放量涨停的个股

HHV(C-REF(C,1)/REF(C,1),3)>9.9%;

通达信N天内经常涨停收盘,但不包括今日?

N:=10;
M:=2;
ZT:=C/REF(C,1)>1.098&&C=H;
T1:=COUNT(ZT,N)>=M;
XG:REF(T1,1)=1&&REF(T1,2)=0;
公式的意思是n天内出现过m次涨停,上面公式是10天内出现过2次涨停,今天不在计算范围内,n和m参数你可以自己调整。


N:=10;
M:=2;
ZT:=C/REF(C,1)>1.098&&C=H;
T1:=COUNT(ZT,N)>=M;
XG:REF(T1,1)=1;
稍加改动这样就变成了只要10天内出现超过2次涨停含2次涨停条件成立

通达信公式,前三天内有涨停,今天跌7个点以上,怎么编公式

REF(COUNT(C/REF(C,1)>1.096 AND C=H,3)>0,1) AND REF(C,1)/C>1.07;

求大神帮忙写两个通达信指标公式。

首先分时图计算的均价线与系统显示的均价线有误差,但你这个思路可以编写,效果如图

通达信搓揉线的指标公式

{揉搓线}
前日上影线:=REF((H-IF(C>O,C,O))/(H-IF(C>O,O,C)),1)*100>60;
前日下影线:=REF((IF(C>O,O,C)-L)/(IF(C>O,C,O)-L),1)*100<30;
上影线:=(H-IF(C>O,C,O))/(H-IF(C>O,O,C))*100<30;
下影线:=(IF(C>O,O,C)-L)/(IF(C>O,C,O)-L)*100>60;
OK:=前日上影线 AND 前日下影线 AND 上影线 AND 下影线;
DRAWTEXT(OK,L,'揉搓线');
STICKLINE(OK,C,O,2.4,0),COLORYELLOW;
将上面的拷贝到主图指标最后一行就行,就能显示搓揉线第二根带长下影线的K线为黄色。
更多的编写教程可以参照
轻松学会用通达信软件编写公式和指标1
轻松学会用通达信软件编写公式和指标2
.......
https://kuaibao.qq.com/s/20190111A1I1S900
https://kuaibao.qq.com/s/20190112A0U91P00